My bug is ...

PlayUp keeps exporting .dae instead .fbx

Sketchup 2016, newest Playup + plugin versions (I installed them just now for first time). UE4 4.12.0, selected ue4 + fbx in sketchup plugin settings, yet it keeps exporting to .dae format instead .fbx. Restarting sketchup doesn't help.

6 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    nameless shared this idea  ·   ·  Admin →

    6 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • SomeName commented  · 

        I created a backup copy of my Sketchup file and wrote a Ruby script to rename all component and component instances. Now it exports successfully.

        In general, I wouldn't expect the average user to be able to open up the ruby console, read a stack trace and understand that their file name was not parsed correctly - then proceed to write a script to rename hundreds of components.

        Instead the PlayUp plugin should be updated to:

        - Use popup dialogue boxes to display user friendly error messages.
        - Automatically validate file names.
        - Parse and escape illegal characters such as quotes.

        In it's current state, without me writing my own plugin to do the above beforehand this plugin is unusable for my clients.

      • SomeName commented  · 

        I am experiencing this as well.

        My Sketchup file has literally hundreds of items with single and double quotes in their names. This is a convention the designers user for measurements. This tool is unable to process single and double quotes, so it just breaks before it converts to FBX.

        Unless someone has a script to mass rename items in Sketchup using REGEX I think I may need to abandon PlayUp Tools - as it is unusable.

      • Anonymous commented  · 

        Thanks, I tried it with a subset of the model where I renamed everything and that fixed it. It seems that spaces are okay.

      • AdminNintari (Owner, PlayUp Tools) commented  · 

        I suspect it may be the naming convention.

        Column - Balcony Front 6".dae <-- Game engines want clean names without odd symbols.

        Try changing this to something like: Column_Balcony_Front_6in

      • Anonymous commented  · 

        Same problem with Sketchup 2017. Here is the text of the ruby console:

        Error: #<Errno::EINVAL: Invalid argument @ rb_sysopen - C:/Users/trent/Desktop/Unreal/Paradise/Column - Balcony Front 6".dae>
        c:/users/trent/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/playup/exporter.rbe:352:in `initialize'
        c:/users/trent/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/playup/exporter.rbe:352:in `open'
        c:/users/trent/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/playup/exporter.rbe:352:in `export_current'
        c:/users/trent/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/playup/exporter.rbe:501:in `block in export_this'
        c:/users/trent/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/playup/exporter.rbe:498:in `each'
        c:/users/trent/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/playup/exporter.rbe:498:in `export_this'
        c:/users/trent/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/playup/exporter.rbe:97:in `process'
        c:/users/trent/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/playup/pipeline.rbe:416:in `init'
        c:/users/trent/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/playup/commands.rbe:114:in `export_to_engine'
        c:/users/trent/appdata/roaming/sketchup/sketchup 2017/sketchup/plugins/playup/commands.rbe:134:in `block in export_level'
        SketchUp:1:in `call'

        I don't see any batch files in the export directory. I'm not trying to export any textures.

      • AdminNintari (Owner, PlayUp Tools) commented  · 

        See the troubleshooting section to be sure that you aren't running into some common issues:
        http://www.playuptools.com/guides/basics-troubleshooting.html

        If that doesn't solve your problem, in the PlayUp Preferences window under the General tab, uncheck the box for "Clean up source files on export". Open your Ruby Console in SketchUp and re-export. Does the Ruby Console show any errors?

        Look in your export directory. You should now see a temporary folder that contains a couple of batch files-- one for reprocessing the textures manually and one for reprocessing the meshes manually. Try reprocessing the meshes if they have not been converted to FBX and see what error it gives.

      Feedback and Knowledge Base